» 윈도우 서버+가상화 » Exchange Server 2013: DAG(데이터베이스 사용 가능 그룹) 구성

Exchange Server 2013: DAG(데이터베이스 사용 가능 그룹) 구성

위 링크를 참고. 역시 명불허전

clip_image001

컴퓨터 개체를 만듦.

clip_image002

DAG라는 이름을 주고 확인

clip_image003

계정 사용 안 함

clip_image004

속성

clip_image005

보안에서 추가

clip_image006

Exchange Trusted Subsystem 추가

clip_image007

Exchange Trusted Subsystem에 모든 권한 부여

clip_image010

Witness 서버로 쓸 WAC 가상 컴퓨터에 파일 서버 설치

clip_image011

‘Windows 방화벽에서 앱 허용’ 선택

clip_image012

파일 및 프린터 공유에 체크되어 있는지 확인

clip_image013

WAC 서버의 컴퓨터 관리

clip_image014

로컬 사용자 및 그룹 -> 그룹의 Administrators의 속성을 본다

clip_image015

추가

clip_image016

Exchange Trusted Subsystem 추가

clip_image017

요래요래 되면 OK.

clip_image018

새로 만들기

clip_image019

나는 위와 같이 구성했음.

clip_image020

※ 미러링 모니터 서버로 WAC을 사용.

clip_image021

DAG 구성원 관리 클릭

clip_image022

추가

clip_image023

서버를 선택하고 추가

clip_image024

제법 시간이 걸린다…

clip_image025

완료!

clip_image026

음… 제대로 되나 해볼까?

clip_image027

WAC 서버의 D 드라이브에 DAG 폴더가 생겼고,

clip_image028

뭔가 이런 파일이 들어 있다.

— DAG에 Mailbox DB 배치해보기 —

clip_image029

기본으로 만들어 두었던 Mailbox01을 분리하고,

clip_image030

…(자세히)을 눌러 데이터베이스 복사본 추가.

clip_image031

*사서함 서버 지정 우측의 ‘찾아보기’

clip_image032

서버 선택

clip_image033

저장. (활성화 기본 설정 번호는 무엇인지 잘 모르겠다.)

Add-MailboxDatabaseCopy cmdlet에 대한 위 예에서 ActivationPreference 매개 변수는 지정되지 않았습니다. 추가된 각 복사본을 사용하여 활성화 기본 설정 번호가 자동으로 증가합니다. 원본 데이터베이스는 항상 우선 설정 번호 1을 갖고, Add-MailboxDatabaseCopycmdlet을 사용하여 추가된 첫 복사본에 우선 설정 번호 2가 자동으로 할당되며, 제거되는 복사본이 없다는 가정 하에 그 다음 추가된 복사본에 우선 설정 번호 3이 할당됩니다. 따라서, 위 예에서는 활성 복사본과 같은 데이터 센터의 수동 복사본이 활성화 우선 설정 번호 2를 갖고, 원격 데이터 센터의 지연되지 않은 수동 복사본이 활성화 우선 설정 번호 3을 가지며, 원격 데이터 센터의 지연된 수동 복사본이 활성화 우선 설정 번호 4를 갖습니다.
출처: <https://technet.microsoft.com/ko-kr/library/dd638129(v=exchg.150).aspx>

clip_image034

적용하는 데 시간이 좀 걸린다. 오류?!

오류
Mailbox01
시드 작업이 실패했습니다. 오류: 필수 구성 요소 검사를 실행하는 동안 오류가 발생했습니다. 오류: 데이터베이스 ‘Mailbox01’이(가) 탑재되지 않았습니다. Mount-Database를 사용하여 데이터베이스 복사본을 시드하기 전에 데이터베이스를 탑재하십시오.. [데이터베이스: Mailbox01, 서버: EX2.archmond.com]

위와 같은 문제가 생김. 왜일까? 탑재를 다시 해봤다.

clip_image035

흐앙 이런 상태. ‘다시 동기화 중’이라는 메시지에 희망을 가져봄.

clip_image036

오호라 EX2 서버에도 D 드라이브에 Mailbox, Mailbox01 이란 폴더 형식(EX1 서버와 동일)이 생겼고,

clip_image037

좀 있으니 자동으로 로그까지 다 생성되었다. 우와! ㅋㅋ

clip_image038

DAG가 활성화 되어서 그런지 ‘사용’ 상태로 자동 전환됨.

clip_image039

‘콘텐츠 인덱스 상태’가 실패인 복사본을 활성화

clip_image040

잘됐으면.

clip_image041

오오 정상이다!

clip_image042

처음에는 Get-MailboxDatabaseCopyStatus가 ContentIndexState: Failed이었다가

clip_image043

Healthy로 바뀜. ^^

(덧)

clip_image001[4]

서버가 켜지고 꺼지는 것에 대해 거의 즉각적으로 반응하는 듯…

이것도 살펴보세요!

Azure Cloud Shell(Linux Bash)

에헹? Azure Portal에서 Linux Bash가? 콘솔 버튼이 생겼다! 아마 Bash or PowerShell로 적용 가능할 것 …

답글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다.